Service Status Page

Offline Mode - 5/30
Incident Report for Lightspeed (U-Series)
Resolved
This incident has been resolved.
Posted May 30, 2022 - 10:21 EDT
Investigating
Our engineering team is investigating connectivity issues and your Upserve Point of Sale may be in Offline Mode.

Offline Mode allows you to continue operating and collecting credit card payments. More on offline mode here: https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside and https://help.upserve.com/s/article/Offline-Mode-Overview.
Posted May 30, 2022 - 08:14 EDT
This incident affected: U-Series POS App and HQ.