Service Status Page

Payment Declines
Incident Report for Lightspeed (U-Series)
Resolved
Our third party partner has resolved the incident and your Point of Sale should be operating continuously online.
Posted Nov 18, 2022 - 21:27 EST
Monitoring
Our engineers have observed credit card decline rates return to expected levels and restaurants that had been operating in offline mode have returned to normal operation.

We are continuing to monitor resolution of the service disruption by one of our third party payment processors, and will update you again before fully resolving this incident.
Posted Nov 18, 2022 - 20:55 EST
Identified
One of our third party payment processors is investigating higher than normal decline rates on credit card transactions. Your U-Series Point of Sale may be in Offline Mode as a result.

Offline mode allows you to continue operating and collecting credit card payments. For more information on offline mode, visit https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside
Posted Nov 18, 2022 - 20:39 EST
Update
We are continuing to investigate this issue.
Posted Nov 18, 2022 - 20:10 EST
Investigating
One of our third party payment processors is investigating higher than normal decline rates on credit card transactions. Your U-Series Point of Sale may be in Offline Mode as a result.

Offline mode allows you to continue operating and collecting credit card payments. For more information on offline mode, visit help.upserve.com
Posted Nov 18, 2022 - 19:57 EST
This incident affected: U-Series POS App and HQ and U-Series Payments.