Service Status Page

Support Toll Free Number
Incident Report for Lightspeed (U-Series)
Resolved
Upserve's 3rd Party host for our toll-free Support number has confirmed that they are nearing incident resolution. Continued testing has confirmed that our toll-free Support number is now fully operational.
Posted Dec 28, 2020 - 17:18 EST
Monitoring
Upserve Support continues to monitor an incident with our 3rd Party host for our toll-free Support number. Inbound calls have now begun to successfully connect. We will provide a further update when we receive confirmation that our 3rd Party Partner has resolved their incident.

Live chat support remains available at help.upserve.com or inside the Upserve HQ, Upserve POS or Upserve Live apps.
Posted Dec 28, 2020 - 16:39 EST
Investigating
The Upserve phone support toll free number is currently unavailable due to a problem our third party phone system partner is experiencing. The Upserve platform remains 100% fully functional and is operating normally. Our technical operations team is working with our third party phone provider to resolve their issue.

Live chat support remains available at help.upserve.com or inside the Upserve HQ, Upserve POS or Upserve Live apps.
Posted Dec 28, 2020 - 15:20 EST
This incident affected: U-Series Support.