Service Status Page

Upserve Login Delay
Incident Report for Lightspeed (U-Series)
Resolved
Login delays caused by the 3rd party authentication provider are now resolved. All Upserve infrastructure has remained operational during this time. If you have any questions, please contact our support team.
Posted Dec 19, 2019 - 14:26 EST
Monitoring
Upserve has identified some users experiencing a delay to login due to an incident caused by a 3rd party authentication provider. Logged in users are not affected. All Upserve infrastructure remains operational. Upserve will continue to monitor this delay and provide an update upon resolution.
Posted Dec 19, 2019 - 13:03 EST
This incident affected: U-Series POS App and HQ.