Service Status Page

Third Party Service Interruption
Incident Report for Lightspeed (U-Series)
Resolved
Continued monitoring of Upserve's systems has shown that the impact caused by an incident at Cloudflare, a Third Party Provider, has been resolved. Upserve customers should continue to see improvement in system performance as normal operations are restored. Upserve internal systems have remained online and Upserve Support can be reached via Phone or Chat as needed.
Posted Jul 17, 2020 - 18:49 EDT
Monitoring
Our 3rd Party Provider, CloudFlare, has released a fix to remedy their service interruption. Impacted Upserve Customers should see any symptomatic behavior remedied shortly. Upserve Engineers continue to monitor the situation and all Upserve internal systems remain online. Upserve Support can now be reached via Phone or Chat.
Posted Jul 17, 2020 - 18:30 EDT
Identified
Upserve Engineers have identified that the current service interruption is the result of an ongoing incident at a 3rd party provider, CloudFlare, and is the likely cause of broad impact to many technology platforms. Upserve internal systems remain online. Please note this incident appears to also be impacting our telephony vendor and it is recommended that you reach us via Chat support within Upserve HQ or at help.upserve.com
Posted Jul 17, 2020 - 18:08 EDT
Investigating
Our engineering team is investigating connectivity issues and your Upserve Point of Sale may be in Offline Mode. Offline Mode allows you to continue operating and collecting credit card payments. Please note this incident appears to also be impacting our telephony vendor as well as other 3rd parties and may impact your wait time to reach an agent.
Posted Jul 17, 2020 - 17:50 EDT
This incident affected: U-Series POS App and HQ and U-Series Support.