Service Status Page

Workforce Loading Intermittently
Incident Report for Lightspeed (U-Series)
Resolved
This incident has been resolved.
Posted Dec 09, 2022 - 03:47 EST
Update
The root cause has been identified and a solution applied.
Posted Dec 08, 2022 - 21:13 EST
Identified
Our engineering team has identified the issue with Workforce and are working on a fix.
Posted Dec 08, 2022 - 17:36 EST
Investigating
We have received reports of customers being unable to access the Workforce Scheduling Tool. Our engineering team is investigating the issue.
Posted Dec 08, 2022 - 15:45 EST
This incident affected: U-Series POS App and HQ.