Service Status Page

U-Series POS Reports
Incident Report for Lightspeed (U-Series)
Resolved
Our engineering team has implemented a solution to address the issue that was causing challenges for certain merchants in generating U-Series POS Reports. Those merchants who previously faced difficulties in generating U-Series POS reports should now experience a return to regular operation.
Posted Nov 14, 2023 - 13:07 EST
Update
We have identified an issue that is causing a very small subset of customers to encounter difficulty when generating U-Series POS Reports.
Posted Nov 14, 2023 - 12:07 EST
Identified
We identified an issue causing some customers to have difficulty generating U-Series POS Reports.
Posted Nov 14, 2023 - 10:30 EST
This incident affected: U-Series POS App and HQ.