Service Status Page

Upserve Point of Sale Maintenance
Incident Report for Lightspeed (U-Series)
Resolved
Our engineering team has completed maintenance on Upserve Point of Sale systems. Your Upserve Point of Sale should now be operating as normal.
Posted Aug 27, 2019 - 16:59 EDT
Identified
Our engineering team is currently performing maintenance to key Point of Sale systems. Your Upserve Point of Sale may be in Offline Mode. If you are experiencing offline mode, you can expect normal operation to resume shortly.

Offline Mode allows you to continue operating and collecting credit card payments. More on offline mode here: http://bit.ly/bcomode.
Posted Aug 27, 2019 - 16:16 EDT
This incident affected: U-Series POS App and HQ.