Service Status Page

Amazon Web Services Outage
Incident Report for Lightspeed (U-Series)
Resolved
Upserve has confirmed that our 3rd party partner, Amazon Web Services has resolved their incident resulting in delayed synchronization for some Upserve customers. At this time all systems are fully operational. Should you require any additional assistance please reach Support via chat at help.Upserve.com.
Posted Nov 26, 2020 - 09:30 EST
Update
The Upserve Engineering team continues to monitor the outage at Amazon Web Services. At this time, service has been restored but traffic levels remain low. Customers experiencing latency will continue to see improvement as AWS increases traffic volumes. As a result, Upserve will continue to monitor the situation carefully. Should you need further assistance please feel free to reach at live chat agent at help.Upserve.com
Posted Nov 25, 2020 - 22:58 EST
Update
The Upserve Engineering team continues to monitor the outage at Amazon Web Services and has taken action to minimize the impact on synchronization services. We will continue to provide updates as events warrant. At this time, AWS has provided no eta for resolution. AWS publishes updates at its status page, https://status.aws.amazon.com/. Should you need further assistance please feel free to reach a live chat agent at help.Upserve.com
Posted Nov 25, 2020 - 18:01 EST
Monitoring
The Upserve Engineering team continues to monitor the outage at Amazon Web Services and take mitigating actions to alleviate its impact on synchronization services. We continue to see improvement in the synchronization of Online Orders, as well as phone call quality to our Support center. Should you need further assistance please feel free to reach at live chat agent at help.Upserve.com
Posted Nov 25, 2020 - 16:00 EST
Update
The Upserve Engineering team continues to monitor the outage at Amazon Web Services and take mitigating actions to alleviate its impact on synchronization services. Please note this incident also may be impacting call quality when calling to Upserve Support. Should you need further assistance please feel free to reach at live chat agent at help.Upserve.com
Posted Nov 25, 2020 - 15:00 EST
Identified
The Upserve Engineering team has identified an issue related to an ongoing outage at Amazon Web Services. Some customers may be experiencing delays in synchronization with remote services including online ordering and point of sale terminals. Upserve engineers are working to mitigate the impact of the Amazon Web Services outage. Updates will continue to be provided until the problem is resolved. Should you need further assistance please feel free to reach a Live Chat Agent at help.upserve.com.
Posted Nov 25, 2020 - 14:02 EST
This incident affected: U-Series POS App and HQ and U-Series Support.