Service Status Page

Email Notifications Not Sending
Incident Report for Lightspeed (U-Series)
Resolved
Since our last update, we have observed email notifications for Daily Digest and Summary, Workforce, and Online Gift Card Purchases being sent successfully from our 3rd Party Email Notification Provider.

If you have any questions, please contact our support team via chat in-app or at help.upserve.com.
Posted Jun 11, 2022 - 10:08 EDT
Identified
Our engineering team has identified an issue with our 3rd Party Email Notification Provider. This affects emails generated from the Daily Digest and Summary, Workforce, and Online Gift Card Purchases.

The team has implemented a workaround for U-Series Online Ordering so that merchant and customer-facing order emails are delivered.

Upserve Point of Sale and Payment Processing platform remain 100% operational at this time.
Posted Jun 10, 2022 - 18:15 EDT
Investigating
Our engineering team is actively investigating an issue with our 3rd Party Email Notification Provider. This affects emails generated from the Upserve Online Ordering Platform, Daily Digest and Summary, Workforce, and Online Gift Card Purchases.

Upserve Point of Sale and Payment Processing platform remain 100% operational at this time.
Posted Jun 10, 2022 - 14:55 EDT
This incident affected: U-Series POS App and HQ.