Service Status Page

eCard Gift Card Provider Incident
Incident Report for Lightspeed (U-Series)
Resolved
The incident with utilizing Gift Cards, is now fully resolved. You can continue to redeem, check balance, and load Gift Cards.
If you have any questions, please contact our support team via chat in-app or at help.upserve.com.
Posted Aug 27, 2023 - 20:59 EDT
Investigating
There is currently an issue with an upstream Gift Card provider, eCard Systems. Our team is reaching out to eCards for more details. They are aware and working on it currently.
Posted Aug 27, 2023 - 20:28 EDT
This incident affected: U-Series Payments.