Service Status Page

Elevated Rate of Card Declines from 13:10-13:25 ET
Incident Report for Lightspeed (U-Series)
Resolved
Beginning at approximately 1:10 pm ET, we saw an elevated rate of certain credit card payment transactions being declined. By 1:25 pm ET, payment authorizations returned fully to normal acceptance levels, and re-attempting previously declined payments resulted in success. Our team has monitored normal card acceptance rates on all authorizations since that time, and is now marking this incident as resolved.
Posted Jun 14, 2018 - 13:46 EDT
Identified
Beginning at approximately 13:10 ET, we saw an elevated rate of certain credit card payment transactions being declined. As of 13:25 ET, payment authorizations have returned to normal levels. Our team continues to monitor, and we will mark this as fully resolved in 15 minutes after continued monitoring.
Posted Jun 14, 2018 - 13:32 EDT
This incident affected: U-Series Payments.