Service Status Page

Canceled Pre-Orders
Incident Report for Lightspeed (U-Series)
Resolved
Upserve Engineers have released a fix to remedy the issue with pre-order checks canceling unexpectedly. All Upserve systems and infrastructure are operational.
Posted Jun 12, 2020 - 19:21 EDT
Update
Upserve Engineers continue to work toward resolving the issue with pre-order checks canceling unexpectedly. Currently, there is no impact to accepting active orders and all Upserve infrastructure remains operational.
Posted Jun 12, 2020 - 18:55 EDT
Identified
Upserve Engineers have identified root cause of the issue with pre-order checks canceling. Testing continues as we move toward resolution. Currently, there is no impact to accepting active orders and all Upserve infrastructure remains operational.
Posted Jun 12, 2020 - 17:54 EDT
Update
Upserve Engineers have identified an issue with pre-order checks canceling unexpectedly and continue to investigate root cause. Currently there is no impact to accepting active orders and all Upserve infrastructure remains operational.
Posted Jun 12, 2020 - 17:21 EDT
Investigating
Upserve Engineers are currently investigating reports of unexpectedly cancelled pre-order checks. Currently there is no impact to accepting active orders and all Upserve infrastructure remains operational. For continued updates, please visit status.upserve.com
Posted Jun 12, 2020 - 16:50 EDT
This incident affected: U-Series POS App and HQ.