07/21/2026 Upserve Inventory Degradation

Incident Report for Upserve

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 21, 2026 - 19:14 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 21, 2026 - 17:02 EDT

Investigating

The Upserve engineering team is aware of an issue affecting Upserve Inventory, including reporting and the inability to edit counts. A fix is in progress, and customers should begin seeing recovery over the next few hours. Until then, customers may continue to experience degraded performance. We'll post another update once the issue is fully resolved.
Posted Jul 21, 2026 - 17:00 EDT
This incident affects: U-Series Inventory.