Service Status Page

Phone Systems Outage 5/13/18
Incident Report for Lightspeed (U-Series)
Resolved
The issue with our third-party phone system provider is resolved and our support phone lines are back to our primary system. Throughout this third-party phone system issue, the Upserve platform remained unaffected and 100% available. Our friendly support agents are able to take your calls, chats and emails. Thank you, and Happy Mother's Day.
Posted May 13, 2018 - 12:34 EDT
Update
Upserve Support has now enabled redundant telephone capacity while our third party phone system provider works to resolve their incident. The Upserve platform remains 100% fully functional and is operating normally. Chat and Email support channels remain available for any immediate support needs. Chats can be initiated from Upserve HQ, Breadcrumb HQ, Upserve Live, or our support page at https://help.upserve.com/s/
Posted May 13, 2018 - 10:56 EDT
Identified
The Upserve phone support toll free number is currently unavailable due to a problem our third party phone system partner is experiencing. The Upserve platform remains 100% fully functional and is operating normally. Our support team is working with our third party phone provider to resolve their issue. Chat and Email support channels remain available for any immediate support needs. Chats can be initiated from Upserve HQ, Breadcrumb HQ, Upserve Live, or our support page at https://help.upserve.com/s/
Posted May 13, 2018 - 08:56 EDT
Investigating
Upserve Support phone systems are currently non-operational. Chat support remains available via Upserve HQ, Breadcrumb HQ, and the Upserve Live Mobile App. Our team is currently investigating root cause and will be updating shortly.
Posted May 13, 2018 - 08:32 EDT