Service Status Page

Support Chat Option Unavailable - 3/30
Incident Report for Lightspeed (U-Series)
Resolved
Our 3rd party chat provider, has resolved an incident with their chat service. Customers contacting Upserve support via chat will now able to reach a support agent in-app or on help.upserve.com. Upserve platform infrastructure is and remains 100% functional
Posted Mar 30, 2023 - 16:01 EDT
Monitoring
Our 3rd party chat provider, has resolved an incident with their chat service. Customers contacting U-Series support via chat will now able to reach a support agent in-app or on help.upserve.com. U-Series platform infrastructure is and remains 100% functional.
Posted Mar 30, 2023 - 15:56 EDT
Investigating
Lightspeed U-Series technical operations team is actively investigating reports of chat-based support experiencing connectivity issues due to a Third Party partner.

Our support team remains available via phone at (855) 664-3887. Upserve platform infrastructure and remains 100% functional.
Posted Mar 30, 2023 - 15:33 EDT
This incident affected: U-Series Support.