Service Status Page

Gift Card Processing Issue- TCC
Incident Report for Lightspeed (U-Series)
Resolved
We have seen recovery with gift cards for TCC a 3rd party integration.

Please note that Upserve infrastructure is still 100% functional.

Please contact us through chat if you see any further issues.
Posted Dec 23, 2022 - 10:19 EST
Investigating
There are currently reports of a 3rd party Incident for merchants utilizing gift cards. Our team is reaching out to TCC, The Customer Connection, for more details.

Please note that Upserve infrastructure is 100% functional.
Posted Dec 22, 2022 - 19:41 EST
This incident affected: 3rd Party Gift Card Partners (The Customer Connection (TCC)).