Service Status Page

3rd Party Phone System Incident
Incident Report for Lightspeed (U-Series)
Resolved
The issue with our third-party phone system provider is resolved and our support phone lines are back to our primary system. Throughout this third-party phone system issue, the Upserve platform remained unaffected and 100% available.
Posted May 15, 2019 - 18:16 EDT
Update
While our 3rd party phone provider is repairing the toll free phone number, our support team is available by phone at 401-415-6738.
Posted May 15, 2019 - 17:59 EDT
Identified
The Upserve phone support toll free number is currently unavailable due to a problem our third party phone system partner is experiencing. The Upserve platform remains 100% fully functional and is operating normally. Our technical operations team is working with our third party phone provider to resolve their issue.

Live chat support remains available at help.upserve.com or inside the Upserve HQ, Upserve POS or Upserve Live apps.
Posted May 15, 2019 - 17:47 EDT
This incident affected: U-Series Support.