Service Status Page

Delays in accessing reports
Incident Report for Lightspeed (U-Series)
Resolved
Upserve Engineering has implemented controls to allow for an improved experience in accessing Reports. Please note that periods of heavy traffic persist and can impact load times. If you are in need of sales reports for SBA loans please reach out to Upserve Support at upservesupport@upserve.com with your Venue Name, Merchant ID (MID) or Tax ID Number (TIN) and the necessary reports will be emailed to you.
Posted May 03, 2021 - 17:20 EDT
Identified
Upserve is experiencing periods of large traffic volume to Upserve HQ Reports, causing performance impacts when accessing reports, particularly across our back office platforms (reports.breadcrumb.com and hq.upserve.com). The infrastructure team is taking steps to mitigate performance impacts during periods of high volume. All Point of Sale and payments functions remain operational.
Posted May 03, 2021 - 13:30 EDT
This incident affected: U-Series POS App and HQ.