Service Status Page

Support Chat Option Unavailable - 6/2
Incident Report for Lightspeed (U-Series)
Resolved
Our 3rd party chat provider has resolved an incident with their chat service. Customers contacting Upserve support via chat will now able to reach a support agent in-app or on help.upserve.com. Upserve platform infrastructure is and remains 100% functional.
Posted Jun 02, 2022 - 18:47 EDT
Investigating
Upserve’s technical operations team is actively investigating reports of chat-based support experiencing connectivity issues.

Our support team remains available via phone at (855) 664-3887. Upserve platform infrastructure and remains 100% functional.
Posted Jun 02, 2022 - 17:00 EDT
This incident affected: U-Series Support.