Service Status Page

Support Phone System

Incident Report for Lightspeed (U-Series)

Resolved

Service has been restored by our 3rd party phone provider to the toll free number for support, 888-514-4644.

All Upserve POS, payments, and analytical services have been and remain 100% functional.
Posted Mar 01, 2018 - 14:29 EST

Identified

Our toll-free support phone line is currently unavailable due to an incident at our 3rd party phone provider. While this incident is ongoing, you can call (401) 415-6738 to be directly connected to our support team. Additionally, you can chat with us at help.upserve.com, Breadcrumb HQ, or in-app.

Please note that all Upserve POS, payments, and analytical services are 100% operational.
Posted Mar 01, 2018 - 13:20 EST