Service Status Page

U-Series Analytics Login Failure
Incident Report for Lightspeed (U-Series)
Resolved
Our engineering team has resolved the issue that was causing difficulties for some merchants logging into HQ at app.upserve.com. Merchants who previously encountered difficulties while attempting to log in should now be able to do so without any issues.
Posted Mar 16, 2023 - 20:20 EDT
Monitoring
Our engineering team has implemented a fix to the issue that was causing difficulties for some merchants logging into app.upserve.com.
Posted Mar 16, 2023 - 19:15 EDT
Identified
Our engineering team has identified an issue with the standalone analytics at app.upserve.com. Resolution is now underway.
Posted Mar 16, 2023 - 18:53 EDT
This incident affected: U-Series POS App and HQ.