Service Status Page

4/29/2025 Reporting Delay for a subset customers

Incident Report for Lightspeed (U-Series)

Resolved

Since our last update, we have observed hq.upserve.com’s performance at normal levels and restaurants have returned to normal operation. This incident has been resolved.
Posted Apr 29, 2025 - 19:56 EDT

Monitoring

Our engineering team has applied a fix for the issue causing a subset of merchants to have reporting delay. We have observed merchants return to normal operations.

We will continue to monitor this issue before resolving.
Posted Apr 29, 2025 - 19:29 EDT

Identified

Our engineering team has identified a problem affecting a subset of merchants experiencing issues with hq.upserve.com. As a result, your reports may be delayed. We are actively working on a resolution
Posted Apr 29, 2025 - 16:41 EDT
This incident affected: U-Series POS App and HQ.