Service Status Page

Lightspeed U-Series POS Incident - 11/15
Incident Report for Lightspeed (U-Series)
Resolved
This incident has been resolved.
Posted Nov 22, 2023 - 13:21 EST
Update
Our engineering team has successfully completed the reinstatement of all recoverable data in relation to the November 15th Google Cloud Platform outage that affected U-Series customers. These recovery efforts include both payments and HQ reporting. All payments are captured and all information in HQ is up to date.

If there are still inconsistencies in your payments or reporting, or if you have any questions, please reach out to support via chat at help.upserve.com or via phone at 855-664-8335.
Posted Nov 22, 2023 - 13:19 EST
Update
Our engineering team is making progress on reconciling delayed reporting data in response to the November 15th U-Series outage. Our focus this week remains on recovering as much of this data as possible. While this occurs, HQ reporting will remain inconsistent.

All delayed payments from the outage were captured last week and should have been deposited today in correlation with the normal deposit schedule. To view the U-Series deposit schedule, please visit https://help.upserve.com/s/article/Deposit-Schedule-with-Upserve-Payments.

For the best performance, make sure all your terminals are running the latest version of the application available in the app store, if you haven't already done so.

If you have any questions please reach out via chat at https://help.upserve.com/s/ or via phone at 855-664-3887.
Posted Nov 20, 2023 - 11:54 EST
Update
Our engineering team has successfully completed the capturing of all delayed payments from the November 15th U-Series outage. These payments will be deposited on Monday in correlation with the normal deposit schedule.

HQ Reports remain inconsistent and our team will now shift focus to reconciling this data next week. To view the U-Series deposit schedule, please visit https://help.upserve.com/s/article/Deposit-Schedule-with-Upserve-Payments. If you have any questions please reach out via chat at https://help.upserve.com/s/ or via phone at 855-664-3887.
Posted Nov 18, 2023 - 00:03 EST
Update
Our engineering team has begun successfully capturing delayed payments from the November 15th U-Series Outage. This process will continue throughout the weekend. Note that this work only affects payments and that reporting in HQ will continue to be inconsistent until further investigation can be done into potential recovery for that data. Thank you for your continued patience as this process continues in the coming days.

To view the U-Series deposit schedule, please visit https://help.upserve.com/s/article/Deposit-Schedule-with-Upserve-Payments. If you have any questions please reach out via chat at https://help.upserve.com/s/ or via phone at 855-664-3887.
Posted Nov 17, 2023 - 19:24 EST
Update
Our engineering team has worked with our third-party provider to resolve an incident that caused some merchants to encounter a service disruption. We have observed merchants return to normal operations.

We are still working to correct reporting inconsistencies from the outage. We will continue to provide updates on our status page.
Posted Nov 16, 2023 - 10:11 EST
Monitoring
Our engineering team has worked with our third-party provider to mitigate an issue causing some merchants to encounter a service disruption.

We have observed a gradual recovery with some merchants returning to normal operations that were previously unable to access their Lightspeed U-Series Point of Sale.

We will continue to monitor for the full recovery of all merchants before resolving.
Posted Nov 15, 2023 - 22:12 EST
Update
Our engineering team remains actively engaged with our third-party provider to address the service disruption. Updates will be shared as soon as more information becomes available.

iOS
As a temporary solution, please follow the following steps:
1. Quit the U-Series app
2. Force Offline Mode - Enable airplane mode or turn off wifi
3. Launch the U-Series app
4. Turn airplane mode off or wifi back on

Android
As a temporary solution, please follow the following steps:
1. Unplug the ethernet cable from the ELO terminal or from the wall.
2. Tap the “Try again” button from the error screen.
3. You should see the PIN screen. Pin in as normal.
4. Plug the ethernet cable back in and after a few moments, printing capabilities should be functional.

This will enable the device to operate in Offline Mode.

Operating in Offline Mode permits ongoing business operations, including the collection of credit card payments. Learn more about Offline Mode here: https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside
Posted Nov 15, 2023 - 21:20 EST
Update
Our engineering team is actively working with our third-party provider to reach a resolution for the service disruption. We will provide updates as soon as additional information becomes available.

iOS
As a temporary solution, please follow the following steps:
1. Quit the U-Series app
2. Force Offline Mode - Enable airplane mode or turn off wifi
3. Launch the U-Series app
4. Turn airplane mode off or wifi back on

Android
As a temporary solution, please follow the following steps:
1. Unplug the ethernet cable from ELO terminal or from the wall.
2. Tap the “Try again” button from the error screen.
3. You should see the PIN screen. Pin in as normal.
4. Plug the ethernet cable back in and after a few moments printing capabilities should be functional.

This will enable the device to operate in Offline Mode.

Operating in Offline Mode permits ongoing business operations, including the collection of credit card payments. Learn more about Offline Mode here: https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside
Posted Nov 15, 2023 - 19:39 EST
Update
Our engineering team is actively working with our third-party provider to reach a resolution for the service disruption. We will provide updates as soon as additional information becomes available.

As a temporary solution, please follow the following steps:
1. Quit the U-Series app
2. Force Offline Mode - Enable airplane mode or turn off wifi
3. Launch the U-Series app
4. Turn airplane mode off or wifi back on

This will enable the device to operate in Offline Mode.

Operating in Offline Mode permits ongoing business operations, including the collection of credit card payments. Learn more about Offline Mode here: https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside
Posted Nov 15, 2023 - 18:46 EST
Update
Our engineering team is actively working with our third-party provider to reach a resolution for the service disruption. We will provide updates as soon as additional information becomes available.

As a temporary solution, please follow the following steps:
1. Quit the U-Series app
2. Force Offline Mode - Enable airplane mode or turn off wifi
3. Launch the U-Series app
4. Turn airplane mode off or wifi back on

This will enable the device to operate in Offline Mode.

Operating in Offline Mode permits ongoing business operations, including the collection of credit card payments. Learn more about Offline Mode here: https://help.upserve.com/s/article/Internet-Connectivity-Issues-Android-Tableside
Posted Nov 15, 2023 - 17:11 EST
Identified
Our engineering team has identified an issue due to a 3rd party provider that is causing the Lightspeed U-Series Point of Sale to be non-operational for some merchants. We will continue to update as soon as we have more information.
Posted Nov 15, 2023 - 16:57 EST
Investigating
Our engineering team is aware of an issue that is causing the Lightspeed U-Series Point of Sale to be non-operational for some merchants. We will update as soon as we have more information.
Posted Nov 15, 2023 - 16:37 EST
This incident affected: U-Series POS App and HQ.