Service Status Page

Unexpected Cancellation of Online Orders
Incident Report for Lightspeed (U-Series)
Resolved
Upserve Engineering has confirmed resolution on a fix for the unexpected auto-cancelling of online orders. Should you need further assistance please feel free to reach a live chat agent at help.Upserve.com
Posted Nov 20, 2020 - 18:35 EST
Monitoring
Upserve Engineering has deployed a fix to remedy the unexpected auto-cancelling of online orders. We will continue to monitor to ensure resolution. Should you need further assistance please feel free to reach a live chat agent at help.Upserve.com
Posted Nov 20, 2020 - 18:25 EST
Identified
The Upserve Engineering team has identified an issue impacting some customers, related to online orders being automatically cancelled and are working on resolving the issue. Updates will continue to be provided until the problem is resolved. Should you need further assistance please feel free to reach a Live Chat Agent at help.upserve.com.
Posted Nov 20, 2020 - 18:10 EST
This incident affected: U-Series POS App and HQ.