Service Status Page

3rd Party Processor Interruption
Incident Report for Lightspeed (U-Series)
Resolved
Upserve has observed restored connectivity across First Data services that were previously causing some customers to operate in Offline Mode. At this time all Upserve systems are fully operational. If you continue to experience issues with credit card processing or remain in Offline Mode, please reach Support via chat at help.Upserve.com.
Posted Feb 26, 2021 - 18:01 EST
Update
Upserve is continuing to monitor the service interruption with First Data. Some customers utilizing First Data for credit card processing may be experiencing recovery while others may be operating in offline mode. Offline Mode allows you to continue operating and collecting credit card payments. More on offline mode here: http://bit.ly/bcomode.
Posted Feb 26, 2021 - 17:10 EST
Identified
Upserve is continuing to monitor a service interruption with First Data. Customers utilizing First Data infrastructure for credit card processing may experience delays in capturing authorizations or may be operating in offline mode. Offline Mode allows you to continue operating and collecting credit card payments. More on offline mode here: http://bit.ly/bcomode.
Posted Feb 26, 2021 - 12:01 EST
Investigating
Upserve is currently investigating reports of a possible service interruption with First Data. Customers utilizing First Data infrastructure for credit card processing may experience delays in capturing authorizations or may be operating in offline mode. Offline Mode allows you to continue operating and collecting credit card payments. More on offline mode here: http://bit.ly/bcomode.
Posted Feb 26, 2021 - 10:56 EST
This incident affected: 3rd Party Payment Partners (First Data Datawire, First Data Nashville, First Data Rapid Connect).