Service Status Page

Toll Free Calling Unavailable
Incident Report for Lightspeed (U-Series)
Resolved
Upserve's 3rd Party host for our toll-free Support number has confirmed that they are nearing incident resolution. Continued testing has confirmed that our toll-free Support number is now fully operational.
Posted Nov 16, 2020 - 14:30 EST
Monitoring
Upserve Support continues to monitor an incident with our 3rd Party host for our toll-free Support number. Inbound calls have now begun to successfully connect. We will provide a further update when we receive confirmation that our 3rd Party Partner has resolved their incident. As always, chat based support remains available via Upserve HQ or at help.upserve.com
Posted Nov 16, 2020 - 14:04 EST
Identified
Upserve had been made aware that our 3rd Party partner that hosts our toll-free support number may be experiencing an incident. This causes inbound calls to our Support Center to fail. To reach our Support team via phone please dial our direct local number (401) 305 - 2421. Alternatively, chat based support is unaffected and available via Upserve HQ or help.upserve.com. We will continue to update the availability of our toll-free number as soon as possible.
Posted Nov 16, 2020 - 13:32 EST
This incident affected: U-Series Support.